JIP-LINER 線形座標計算システム
Ver.13.17(2020-01-18)
◯LINER
・ショートファイル名を生成しない設定のハードディスクでは .LL1が存在しないという実行エラーになってしまう問題に対処した。これまでもfsutil 8dot3nameでディスクの設定を変更することで対処可能であったが、変更しないでも実行できるように改良した。(Windowsの既定値は「ショートファイル名を生成する」)
・通常の2倍以上の解像度を持つ高DPI環境において、フォントが小さすぎるなど画面バランスが崩れる場合があるため対処した。
・逆に文字を大きくするために表示スケールを低DPIに調整して更に「アプリが鮮明に表示されるようにWindowsにより修正を試す」をオンにしていても表示が乱れないように調整した。
・座標の表示の幅を全12桁から13桁へ広げた。
・データ異常のためにラインや折桁とセクションの交点を計算できないときのエラーメッセージを追加した。

Ver.13.16a(2017-12-18)
◯LINER,LTOOL
・折れ横断とラインの交角として違う象限を表示する場合がある不具合を修正した。(Ver13.16で発生)

Ver.13.16(2017-11-18)
◯LINER
・ひとつのLINERデータに対して複数の線形一般図(GVIEWX)があるときのデータ読み込み方法を見直した。
・卵形クロソイドのデータチェックが過敏な場合があったので調整した。
・GDRAWのスパン構成データで、基準ライン、左端ラインは必須であると明記した。
・TLINERの入力画面にハンチ計算TYPE11の説明を追加した。
・TLINERの入力画面にGVIEWXの描画範囲について以下のように説明を追加した。
既定値では計算ピア名称の最初と最後のピアが橋梁範囲を描画範囲する
変更する場合は橋梁範囲の外側とすること
◯GVIEWX
・線形一般図(GVIEWX)の縦断図、横断図で測点範囲の指定を可能とした。入力はあるが使用できなかった。
・MDSKに横断の始点の記録がないときに小座標変換図などでの描画が異常にならないように対処した。

Ver.13.15a(2016-11-18)
◯LTOOL
・Windowsのレジストリの状態によっては結果の表示が乱れる場合があった。

Ver.13.15(2016-11-18)
◯GDRAW,GDRAW
コンパイラを変更し、また計算精度を向上した。(倍精度対応)
・プロットファイルは.1,.2の組み合わせから.1単独に変更した。
◯LINER
・反向するサイン逓減曲線の実装を見直し、対応を改善した。(「鉄道曲線」神谷進 著の範囲)
・反向するサイン逓減曲線の平行線について計算、描画の実装を見直した。
・反向曲線(サイン逓減曲線、3次逓減曲線)で描画が乱れる場合があったので改善した。R1 = -R2のとき直線で描画しないよう対策を行った。
描画の最適化(点列の最少化)のとき、中間点の弦と弧の差がゼロになるとき打ち切っていたため、R1 = -R2 のとき線分になっていたなど、複数の理由で軌跡が乱れる場合があった。
◯GVIEWX
・ひとつのLINERデータで線形一般図(GVIEWX)の複数データブロックに対応する機能の実装方法を変更した。GVIEWX側で複数データを扱うのはやめ、TLINER側での制御に変更した。
・線形一般図(GVIEWX)のデータブロックを部分的に無効に出来ない場合があった。
・平面図の要素表の変化点名称がずれてしまう場合があった。
◯APLINE
・LINERラインデータ作成の入力画面で、[作成(M)]でデータも保存するが、[終了(X)]では保存しない。まぎらわしくないよう[終了(X)]を[取消(X)]に変更した。
・LINERラインデータ作成の入力画面で、「出力」の列に○がついていないとき (「出力番号」の列は保存していないので) 出力番号をクリアして保存できなかった。変更した数字が復活する場合もあった。
・LINEラインデータ作成の入力画面で、行数がスクロールするほど多いときに、出力番号のセルで矢印キーで移動するとデータがずれる場合があった。
◯PV
・GVIEWXの縦断線形、横断線形をDXF変換すると数値の後ろに[ 0 1]という余計な文字がついてしまう場合があった。PVでの表示は、問題ない。

Ver.13.14(2016-01-18)
□全般
○コンパイラの更新
・計算精度の向上とWindows10など新しいOSへの対応を目的としてコンパイラを更新した。これに伴い、今後WindowsXPは動作検証の対象外となる。
実行時に必要なランタイムがない場合、セットアップ時に一緒にインストールするが、明示的にインストールしたい場合は以下のマイクロソフト社のサイトから vcredist_x86.exe をダウンロードしてもよい。
http://www.microsoft.com/ja-jp/download/details.aspx?id=40784  (IE10以上が必要)

□拡張子とデータ保存動作の変更
○LINER
・データと出力ファイルの拡張子を小文字に統一(小文字化)した。
・バックアップファイルの拡張子は .lim だったが、データと紛らわしいので .bak_lin に変更した。
・ファイルの読み込みの選択ダイアログからはバックアップファイルの読み込みを除いた。
・HAUNCHを変更しただけでは LINERのデータの書式が変わらないような動作に変更した。
・終了時の保存確認を必ず行うかどうかをオプションで選択可能とした。
以下のメニューからオプションを設定すると次回起動時からオプションが有効になる。
「ツール(T)」-「オプション(O)」- [X 終了時に必ず保存の確認を行う]

□描画プログラムの改良
○GDRAW
・描画時のX軸の取り方を「基準ラインと最初・最後の横断」とするオプションを追加した。「軸指定」データを使わない場合はラインを前後に延長した位置を基準にしている。
・拡幅がある卵形の3次逓減曲線を正しく描画できない場合があった。LINERの確認図は正しく描画できていた。
○GVIEWX
・ひとつのLINERデータに対して複数の線形一般図(GVIEWX)の複数データに対応した。プロットファイルはひとつにまとめて出力する。
・MDSKに横断の終点の記録がないときに小座標変換図などでの描画が異常にならないように対処した。LINERのデータを修正することでの対応も可能だがデータによっては困難な場合がある。

□計算精度向上
○LINER
・クロソイド、円弧、3次、サイン低減計算を見直し計算精度を向上させた。これによりクロソイド区間の測点の表示精度などが向上した。小数点5桁めなどが微妙に変わるデータも発生する。
- クロソイド曲線等の計算を見直し計算精度を向上した。LTOOLとも微妙なずれが生じる場合がまれにあった。
- サイン逓減曲線、3次曲線の計算方法を全般的に整理した。
- 反向するサイン逓減曲線がすりつかない場合があった。反向するサイン逓減曲線の終端側のRの絶対値が大きい場合は終端側から計算するようにし、サイン逓減曲線の正射長(パラメータ)を計算するための曲率の変化式の採り方を絶対値に直した。
○HOSO
・最小舗装厚に近い値が複数ある場合に 2点押さえの自動決定で押さえ点の舗装厚が表示上0.1mm ずれる場合があったため、収束を細かくすることで精度を向上するように対策を行った。

□その他
○APLINE,LTOOL
・測点ピッチを1mにしたときの表示方法を変更した。ただし1mピッチは一般には使わない。
    237.379mの場合:
    1000m pitch   0+237.379
     100m pitch   2+37.379
      20m pitch  11+17.379
      10m pitch  23+07.379
       1m pitch   0+237.379 -> 237+0.3790 に修正
○APLINE
・APLINEで要素ごとに帳票出力したときの罫線のずれを修正した。
○LINER
・3点をつなぐ円弧桁が編集できない場合があった。
・データの全角空白を半角空白×2に置き換える動作をやめた。
・NAME出力で測点の出力があり横に長くなる場合にページを囲む罫線に右側の縦棒がない行が発生する場合があった。
○LTOOL
・ウインドウサイズが小さくなって復旧できない場合の対策を行った。

Ver.13.13(2014-11-18)
○全般
・Windows8/8.1のときのインストーラの表示を調整した。Windows8/8.1のUIフォントの変更により表示が間延びしていた。
・APLINE等が使うOCXやDLLの配置を整理した。Windowsのシステムディレクトリに配置していたが、Windows8/7の環境では望ましくないため改善した。
  例) C:\Windows\system32\InterX.ocx → C:\HyBRIDGE\LINER\OPTION\InterX.ocx
- 旧バージョンから上書きインストールすることで自動で再配置を行う。
- クライアントインストールの場合も、そのままでも動くが、クライアント側で改めてクライアントインストールをやり直すのが望ましい。
・サーバーインストールのときOPTION/APLINE,LTOOLのヘルプの右側が表示できない場合があった。
○LINER
・プロットファイルの内容によってDXF変換時のPVの画層変換フィルタの初期値を自動判定するように変更した。
・終了時に保存するかどうかを必ず確認するように変更した。
・折れ横断とラインの交角を求めるときに、隣接する別の区間の線分の交点としてみつかってしまうため別の象限の角度が出てきてしまう場合があった。
・5桁出力時の測点の表示の丸めが正しくない場合があった。
内部数値の距離が11034.9999935466 のとき (ピッチ100として) 4桁表示のとき 110+35.0000 になるが、5桁表示だと 110+34.99999 になってしまい10+35.00000 にはならなかったため、その場合のみ表示を調整するように変更した。
○GVIEWX
・GDRAWと同様にGVIEWXもDXFファイルの実寸化に対応した。
・GVIEWX実行後にPVを開いた時、画層変換フィルタの初期値がGVIEWXになるようにした。
・縦断(横断)線形要素図の橋長の描画にLINERの出力と若干の差がある場合があった。
・測点マイナスピッチのときピア図などを描画できない場合があった。
・縦断勾配(PH)、横断勾配(GR)のデータ行数が多いときにエラーになっていた。
・バッチからのGVIEWXの実行にはTLINERを経由するが、データ不備のためGVIEWXの実行に失敗した場合も成功した場合と同様にTLINERをすぐに終了するよう変更した。
○HAUNCH
・丸めの違いからLINERの高さと異なる数字の箇所があったため修正した。
○HOSO
・天端高の出力時に桁落ちを防ぐための微小値の考慮を追加した。
○GDRAW
・GDRAW実行後にPVを開いた時、画層変換フィルタの初期値がGDRAWになるようにした。
・旗揚げ(名称)の余白の調整について入力画面に補足説明を追加した。
○シェル
・プロットファイルの内容によってDXF変換時のPVの画層変換フィルタの初期値を自動判定するように変更した。
・TV,PRでも帳票(LL2)がTVで開くように変更した。
○OUTLINE
・データ以外のすべてのファイルを削除するメニューを廃止した。
○プロットファイル描画(PV)
・画層を考慮してDXF変換した場合はカラーでの印刷を可能とした。「表示(V)」- 「カラー印刷」でカラー印刷を有効にできる。ただし、DXF形式時の黄色は白地では視認性が悪いため、橙で印刷する。また、LINER(GDRAW,GVIEWX)から出力したプロットファイル拡張子(.1)はモノクロで印刷する。
Ver.13.12(2013-11-18)
○全般
・Windows8での動作を確認した。(32ビット,64ビット日本語版で確認)
○LINER
・大座標のみを出力するオプション(GLOBAL)を追加した。 競合するオプションLOCALがGLOBALに優先する。
・オプションの表示順序を見なおした。
・警告は余白でなく、改ページ後に独立したページに出力するように変更した。
- ||並行による摺り付きの警告
- 基準線へのピアの交点がない場合の警告
・文法チェックで警告があるとき、LL1に出力されている警告相当を画面にも表示する機能を追加した。
・反向するサイン逓減曲線のときにMDSK内の情報が不足するためにGDRAWでの描画が一部おかしくなる場合があった。
・MDSKOUTの説明は「MDO形式出力」に改めた。
・セクションの画面に順番通り指定する必要があることを表示した。
○HOSO
・CSV出力で舗装厚のほかに天端高を出力する機能を追加した。
○GDRAW
・平面図の「四隅を描画しない」が効いていなかった。
○TV
大座標小座標の変更時に、選択中の横断を座標系を変更して自動で再表示するように変更した。
○シェル
・LL2に出力されるエラーや警告も画面に表示する機能を追加した。
○APLINE
・ツリーメニューが起動時に必ずオンになるようにした。
・最大化した画面サイズで起動するように変更した。
・ラインの要素数を50->65に拡張した。
・PCによってはツリーメニューとステータスバーに文字化けが発生する場合があったため対策を行った。

(補足) 以前のバージョンで文字化けが発生する場合はランタイム側の設定で対応可能。
(Windowsシステムフォルダに VB6JP.dllが不足している場合に文字化けが発生する場合がある)
[Visual Basic 6.0 Service Pack 6:ランタイム再頒布可能パッケージ (vbrun60sp6.exe)]
[VB6ランタイムファイル] (MSの配布ファイルで不足する場合の対策あり)
Ver.13.11(2012-11-18)
○LINER
・ツールバーのデザインをフラットに変更した。
・鉄道線形のSIN曲線および3次放物線の正射長の計算時の収束時のイプシロン判定を調整した。小数点以下5桁表示の場合など要素変化点座標(ETC,BC点)が一致せず離れている場合があった。
・クロソイド要素のADDのリカバリの改善を行った。クロソイド要素延長ではBRまたはERを指定しなければいけないが、間違って「R=100」 のように書いてあった場合、 「A=100 R=100」なら「A=100 ER=100」に、 「R=100 A=100」なら「BR=100 A=100」に 直していた。ADDでなければRでよいなど、チェックが難しい箇所なのでリカバリはせずに警告だけ出すように変更した。
・測点ピッチマイナスになる場合の横断勾配(GR)のエラーチェックを強化した。横断勾配(GR)のテーブルで、距離が逆転する箇所のチェックをGUIに追加した。測点設定(STATION)での測点の有効範囲の逆転は検出できない。
・測点ピッチがマイナス時の描画する測点位置の初期値と[<][>]ボタンの調整を行った。描画上の問題であり、計算には影響はない。
・5桁出力時の測点の表示がおかしい場合があった。
誤) 148+53.99999 -> 正)148+53.00000
○GDRAW
・第2車線のセクション引き出し線が編集時に下側になってしまう場合があった。
・描画点数を最適化するために少なくする場合があったが、減らし過ぎないように描画ピッチの制御を見なおした。
・実寸図面をCADで計測した場合の横断上の精度が上がるように描画ピッチの制御を見なおした。従来よりもプロットファイルはやや大きくなる。
・図面描画枠のデフォルトは「なし」から「4隅」に変更した。
・横断名称の描画方向のデフォルトを横断方向に変更した。
・横断線名称の旗揚げ(バルーン)の表示を改良した。
- 名称バルーンのサイズ調整を行った。余白を削り全体に詰めた。
- 横断方向に横断名称を描画する時、ジグザグする描画をやめた。
- 引き出し位置は文字列長によって変えずに一定距離とした。桁端や端支点、中間支点では従来通り多めに引き出す。
- 旗揚げの画層設定は、枠をD-STR-HTXT、名称をD-STR-TXTとしていたが、D-STR-HTXTに統一した。
- DXF変換時の旗揚げの余白に過不足が生じる問題の対策を行った。一文字ずつ描画することで文字ピッチを制御し、旗揚げの枠から文字がはみ出さないよう対策を行った。CADで一括して移動できるようグループ化を追加した。
- 従来のサイズで旗揚げを描画する互換オプションを用意し、オプションの状態をデフォルトとしてある
○GVIEWX
・平面線形、ピア設定方法のピア名称の位置がおかしくなる場合があった。
・存在しないスパン名を指定した時のエラーメッセージを改良した。
・縦断図、横断図の測点表示の文字列をグループ化し、DXF変換後にはCADで一括で移動できるようにした。
・ピア図、座標変換図にDXF変換後に同じ場所に二重に描画してしまう箇所があった。
・平面線形図とその一覧表で測点表示が異なる場合があった。
○APLINE
・LINER連動用データの座標桁数で、小数点以下の桁数を選択(5~7桁)できるようにした。
・「任意の測点での拡幅線」で基準ラインに拡幅クロソイドが含まれているとき、ラインを正しく作成できないが、拡幅クロソイドはシステムの適用外で対応できないため、その旨のメッセージの表示を追加した。
・「ラインと直線の交点計算」で計算方法に「ラインと直線の交点」を選択し、新たな直線を定義したときに入力した直線の2点目が変数にて保持されていなかったため、保持するようにした。
○シェル
・ファイル名が長すぎるとき、GUIでは実行できたが、バッチでは実行できなかったので修正した。
○PV
・DXF変換時のPOLYLINEの擦り付けをSPLINEからFIT-CURVEに変更した。SPLICEのほうが滑らかな関数だが、FIT-CURVEのほうが必ず制御点を通る。
・パス名に.dxfを含むときプロットファイルをDXFファイルと誤認する可能性があった。
・負の半径を持つごく短い円弧のDXF変換の改良を行った。
・BLOCKを有効にしたDXF変換のとき、BLOCKSの外にあるPOLYLINEがENTIEIESにも現れてしまう場合があった。
Ver.13.10(2011-11-18)
○LINER
・断面高さ設定の断面図を左右逆転して表示してしまう場合の対策を行った。
・データによって無限ループに陥いる場合があったため対策を行った。
○PV
・DXF変換において、POLYLINEの破線や一点鎖線が意図通りに表示できるよう線種生成モードをオンにした。
○その他
[Ver13.08以前からVer13.09以降へのアップグレード時のお願い]
・サーバにプログラムを置き、ユーザはクライアントインストールで使用する場合、通常はクライアントPC側の更新は不要ですが、Ver13.08以前からVer13.09以降へのアップグレード時に限り、クライアントPCでもサーバと同一のバージョンで上書きインストールを行う必要があることがわかりました。
・この作業によりAPLINEのサブモジュールを再登録します。行わない場合、APLINEの一部の機能が使用できません。該当する場合、お手数ですが上書でインストールを行なっていただくようお願いします。

[クライアントインストールとは]
導入時のオプションで [x クライアントインストールを行う] にチェックを入れた場合を指します。サーバで一括してプログラムのバージョンを管理できる運用方法です。
Ver.13.09(2011-07-14)
○LINER
・折桁のダイアログで、コンボボックスの最初のラインを方向ラインで選択してもデータに反映できなかった。
○HAUNCH
・TYPE17の場合、交点がない点でも省略せずに計算を行うように変更した。
○GVIEWX
・小座標座標変換図が描画できない場合があった。
○APLINE
・補助計算のライン上の任意点の座標計算で、ラインと直線の交点計算にて算出した結果(ライン、始点からの距離)を継承し、座標計算を行う機能を追加した。
・補助計算のライン上の任意点の座標計算で、計算方法に任意距離および弦長を指定して、座標計算を行う機能を追加した。
・補助計算のライン上の任意点の座標計算で、ラインと直線の交点計算にて算出した結果(ライン、始点からの距離)を継承し、座標計算を行う機能を追加した。
・補助計算のラインとラインの交点で、交点の対象となったラインの要素表を帳票出力できる機能を追加した。
・任意の測点での拡幅線で、1次拡幅に加え、直線を設定できる機能を追加した。
Ver.13.08(2010-12-15)
○LINER
・パス名に空白を含まずにファイル名だけに空白があるときのみショートファイル名への変換を行うように変更した。
ただしすでにショートファイル名だけのファイルが存在するデータパスの場合は従来通り常にショートファイル名への変換を行う。
○GVIEWX
・描画可能なサイズを拡大した。
○APLINE
・ラインとラインの交点計算において、ラインが曲線の場合、画面に表示されるポイントマークと交点がずれる場合があったため、 要素長をもとにした長さで描画するように変更することで改善した。
Ver.13.07(2010-11-18)
○LINER,PV
・直線に近い円弧の描画問題
LINERの描画で円要素を直線に近い巨大な円弧で表示する場合に表示が乱れる場合の対処を行った。
円弧の描画処理はWindowsのAPIの内部でドット単位の整数演算に置き換えられる。 通常はこの精度で問題ないが、直線に近い円弧の場合には意図したピクセルに描画されない場合がありうる。
DXF変換ではAPIを経由しないためこの問題は発生しない。
○LINER
・多人数で使っている共有ドライブにデータをおくなどハードディスクの反応が遅い環境で使っているとき、 画面を高速で切り替えるとディスクの処理が画面の更新に追いつかずに落ちてしまう場合があったため対処した。
○GDRAW
・小座標変換が測量系のとき表のYの符号が反転していた。
・ラインの描画で終点側の座標が正しく描けない場合があった。
・線種を変更するラインの指定で2(=実線0.4mm)が1(=実線0.2mm)になっていた。
○GVIEWX
・平面図の要素表を要素図とは別図面とした。
・平面図の要素表は要素図とは独立に用紙サイズ、スケール、比率の考慮を可能にした。
・A4longなど長尺図面に対応した。
・縦方向、横方向の比率の考慮を可能にした。
・平面図の要素表はタイトルを省略した。
・要素表のライン名はタイトル文字列用の文字高とした。
・描画用の座標変換の方法を見直した。
・用紙サイズを指定して描画できるように変更した。
・PIER図のピアライン,TRAN図のY軸の描画長さを調整した。
・用紙サイズにA6,B6を追加した。
・変化点名称を入力しても表示できない場合があった。
・シェルからも実行可能とした(GUI経由)
○APLINE
・要素表にて、ラインの要素の始終点をポイント登録する機能を追加した。
・非常駐車帯の設定において、基準ラインに要素変化点があるとき、非常駐車帯のラインが正しく作成されない場合がある不具合を修正した。
・要素設定において、前追加にて[補完]を設定した場合、次回起動時に[補完]ができていない場合がある不具合を修正した。
・要素設定において、後追加にて[補完]を設定した場合、次回起動時にエラーメッセージもなく強制終了する場合がある不具合を修正した。
○PV
・DXF変換時に連続するPOLYLINEの最大の上限を撤廃した。
○その他
・セットアップの仕組みを変更した。
Ver.13.06(2010-02-19)
○GVIEWX
・描画範囲のおかしくなるデータがあったため対応した。
○PV
・WC座標で1.0e12超えの値があるとき再描画に失敗する場合があった。±1.0e11までは問題ない。
LINER関連だけで発生する現象。
Ver.13.05(2009-11-18)
○Windows7対応
・Windows7での動作を確認した。(32ビット日本語版で確認。64ビット版は未検証)
○GVIEWX
・線形一般図等を出力するGVIEWXを追加した。
○LINER
・多折桁の描画の扱いの不整合による描画上、操作上の問題を解決した。
・大量の折点をもつ折桁のとき平面図表示ができない場合があった。
・スパン図でライン要素をピックアップできなくなっていた。
・STATIONのNAME出力は常に1項目ずつで保存するようにした。
・SPANデータの基準がLxxxではなくGxxxでも強調して描画するように変更した。
・GUI動作不安定への対応。表示ライン、横断を限定したときに落ちる場合があった。
・実数表示の不具合(LINER2漢字版)
微小値を2重に足しているために漢字版出力と、ANK版,GDRAW,LTOOLで0.1ミリの桁が異なる場合があった。
104.7487499999 -> 104.7488 or 104.7487
・測点→累加長変換の不具合修正
測点の入力で小さな値がなるべく有効になるように測点表の値を累加長に変換するときの微小値の扱いを調整した。
・NAME出力で文字化けがあるためTVで帳票を開けない場合があった。
NAME出力で全角で6文字めが全角文字のとき2バイトめを破壊して文字化け表示になっていた。このときTVで帳票を確認できなかった。
例) 下り線中心線
○HAUNCH
・LINデータ中にハンチのデータパートがないときにテンポラリファイルが残っていた。
○GDRAW,PV
・角度の不具合の修正。セクション名称の向きや囲むマルの不具合を修正した。方位角の算出方法を変更した。
・セクション名称の向きや囲むマルの不具合を修正した。
・「円要素を円弧として描画」した場合に正しく描画されないことがあった。
・DXF変換時の倍精度化プロッタの精度を上げた。
・ブロックを考慮せずにDXF変換し、画層変換を考慮した場合にBYLAYERにならない画層が発生する場合があった。
・交角描画セクション、ライン指定の不具合を修正した。
下記のようなデータのとき、S1はG3との交点に交角を描画するが、PA,S2はCLとの交角を描画していた。
 SECT DATA
 ANGLE : S1 / G3
 ANGLE : P1 / G3
 ANGLE : S2 / G3
○TV
・LINER(LL2,AL2)の帳票でスパン名によっては横断名を拾えない場合があった。
○OPTION/GVIEW, OPTION/GPLOT (CRTCON版)
・UNCパスに実行ファイルがあり、書込み禁止のときでも動くようにした。
○OUTLINE
・#####TOUTLINEの後ろにバージョン番号をつけて保存するのをやめた(2重になる場合あり)
Ver.13.04(2009-01-23)
○LINER
・大量の折点をもつ折桁のとき平面図表示ができない場合があった。
・環境ファイルの修正
Ver13.03以前の環境ファイルのフォーマットを新フォーマットに起動時に修正する。
Ver13.04の初回起動時のみ 「環境ファイルの設定を修正しました..」というメッセージを出力する。
○LINER,TV
・ANK版の帳票で座標変換のトップページでスパン名を20文字しか出力していなかったため、帳票ビューワ(TV)で横断名の一覧を表示できなかった。
○LINER,GDRAW,PV
・曲率半径や拡大範囲によっては円弧が円として描画されてしまう場合があった。
○LINER,OUTLINE
・[F5]キーで計算メニューが開くようにした。
○TV
・LINER(AL2)の帳票でスパン名によっては横断名の一覧を取得できなかった。
○HOSO
・TYPE12で存在しない主桁を指定したとき、警告を出して計算続行するようにした。
○GDRAW
・LINERのOUTPUTデータで出力名称が指定されていないときにエラーメッセージを出してから止めるようにした。
Ver.13.03(2008-11-18)
○LINER
・JIS2004フォント対応(XP SP3) KB927489
WindowsVistaまたはXP SP3でのフォントデザイン変更により一文字分入力できない箇所があるため対応した。
・座標変換毎のトップ頁のスパン名称として20文字までしか出力していなかった。
TVでの頭だしに影響する。
・平面図描画でサイン逓減曲線がすりついていないように見える場合があった。
○HOSO
・舗装計算の収束方法を改良した(TYPE2,TYPE3,TYPE4)。
改良前は収束しないことが多かった。
○OPTION/GVIEWIG
・CL(PH)のように括弧を含む基準線があるときエラーではなく、警告扱いとした。
エラーになるとデータを読めずに計算できない項目が出来てしまう。
Ver.13.02(2008-06-01)
○LINER
・3点をつなぐ円弧桁が編集できなかった。
○GDRAW
・円、円弧の描画精度を改良した。
・GDRAWでスパンがひとつしかないときはセクションの引き出し線が上側にしか描けなかった。
○HOSO
・TLINERの[舗装計算]のボタンが動かなくなっていた不具合を修正した。(Ver13.01で発生)
Ver.13.01(2008-04-01)
○LINER
・座標変換ごとに目印のページを追加し、座標変換のパラメータ(原点、方向など)の表示を追加した。
・数値群形式で数値の数が:の両辺で合わないとき、エラーメッセージに数値の数を表示するようにした。
・GCONVAの単独起動のメニューを復活した。
GCONVAはPVに含まれるため重複しないようVer13.00で削除したが、GVIEWからの出力にも使えるため戻した。
・[オプション]メニューにツリーを切替後、[JIP-LINER]に戻したとき、LDISTのツリーメニューが消えてしまっていた。
・高さチェックのチェックリスト(CHI)の表示メニューを追加した。
・以前のスパンの横断名を含めて横断数最大のチェックを行っていたため、横断名の文字列の登録をスパンごとに行われるよう修正した。
・ラインの要素変化点に描く丸のデフォルトについてのコメントを削除。オンオフのパラメータがないため、省略時は0.1mmではなく描画しない。
・桁設定の描画エリアで、折れセクションの折れ点を○で描画した。
・RECTでラインを設定した場合の要素数をもとに要素毎の平行設定を行うと文法エラーになっていた。
LINER1の段階ではチェックできないのでRECTを使っている場合は警告とし計算を続行するように変更した。
・サイン逓減曲線のパラメータは要素長で入力するが、パラメータに変換した値をMDSKに保存しているため、計算と描画で値の辻褄があわなかった。 正しく計算と描画ができるように統一した。
・ANK版の入力エコーに改頁を追加した。
○GDRAW
・描画時の分割数を上げた。ただし実線で描画しないラインは細かくすると破線や点線に見えないため、分割数は増やさない。
・横断数が多いとき(>100)の進捗表示を追加した。毎回MDSKを読むため横断数が多くなると遅くなる。
・サイン逓減曲線のパラメータは要素長で入力するが、パラメータに変換した値をMDSKに保存しているため、計算と描画で値の辻褄があわなかった。正しく計算と描画ができるように統一した。
・余計な線を描画してしまう場合があったため対応した。
・基準線の要素変化点の描画を見直した。
・データで指定したペンの太さを考慮できなくなっていた不具合を修正した。(Ver13.00で発生)
・GDRAWのスパン構成で2車線めのセクション引き出し線を上側にしても下側に描画されていた。
・GDRAWのスパン構成の画面で[次のデータ」としたときの画面の有効無効の制御を見直した。
○HOSO
・タイプ6(2点押さえ+最大舗装厚最小、体積最小)を書き直した。
従来はライズ量(キャンバー)を考慮していなかった。
○GVIEWIG
・スパン数が多いときに編集できない場合があった。
○SHELL
・LINER1での文法エラー時にエラーメッセージを出し、LINER2を起動しないようにした。
○TV
・LINER(CHI)の帳票を追加した。見出しなし。
・LINER(AL2) ANK版の帳票でも大座標、小座標の区別を可能とした。
・LINER(LL2)の帳票で2スパン目以降の小座標系の頭だしに失敗する場合があった。
・LINER(LL2,AL2)の帳票に追加した座標変換パラメータの表示があればそれを頼りにスパンの頭だしをするように変更した。ない場合は従来の方法による。
・文字のカラム位置の調整を簡略化して高速に印刷するモードを追加した。
高速モード時は通常の7倍ほど速くなるが、通常とは文字間隔などが異なる。
・罫線を無視して印刷するモードを追加した。
○PV
・BY_LAYERで色づけしているDXF形式に対応した。
・DXF変換時に短い点線や破線が連続する場合にPOLYLINEにまとめるようにした。
・DXF変換時の円と円弧の出力フォーマットを%.lf->%.10lfに変更した。
・DXF変換時の小数点以下の精度フラグ(LUPREC)をデフォルトの4から8に変更した。
Ver.13.00(2007-11-18)
○Windows Vista対応
・プロテクトキーを認識するためのファイル(JSPHSP32.DLL)をVista対応版に更新した。
使用するOSにかかわらず、プロテクトに関するユーティリティを最終更新日 07/04/19以降に更新する必要がある。
(プロテクトに関するユーティリティを更新してもVista未対応版のプログラムも実行できます)
・ヘルプファイルの形式を従来のWinHELP形式(HLP)からHTML Help形式(CHM)に変更した。
・Vista対応に伴い、不要となるファイルはインストール時に削除するようセットアップを変更した。
・コンパイラを変更した。
○実寸プロッタに対応(PV,GDRAW)
・DXF変換時に実寸図面への変換を可能とした。ミリメートルまでの精度で1:1の尺度で描画する。 計測単位がミリメートルなので、図面中のすべての単位はミリメートルとなる。 DXF変換後に図面を印刷するときは、尺度を指定するか、イメージを用紙に合わせて行う。
○一般
・電話番号の表記はやめてURLに変更した。
帳票の表紙にある電話番号の表示、ダイアログにある電話番号の表示はやめてURLに直した。
・オンラインマニュアルの表示はフォルダを開くのではなくマニュアル一覧を開くように変更した。
・体験版は廃止する。
○LINER
・SET VOID~RESET VOID間にある%コメントを正しく扱えない場合があった。
・STATIONデータで無効なSTA番号と同じ有効なSTA番号があっても対応するNEGが無効になっていた。
・ピア設定の入力ダイアログの測点入力で、複数測線がある場合、新規に測点入力後、変更しようとダブルクリックでダイアログを表示させると、基準ラインが、コンボボックスの常に1番目になってしまうため、入力した基準ラインを表示するように修正した。
・要素に対する||平行を扱えるようにした。
拡幅タイプのラジオボタンは増設していないので、表の「基準ライン・要素」の列に "|| L10(1)"のように入力する。
・SPANデータの桁編集で以下のようにRが負の場合に「円弧桁」ではなく「複数個の点を結ぶ」タイプの編集ダイアログになっていた。
G101:(L1,S4)*(L1,S5)R=-259
・スパンの出力設定で、PRTSの名前を簡易入力で変更しても表を一度触らない限り変更が保存されなかった。
○GDRAW
・GDRAWの入力で2車線あるデータを1車線に変更できなかった。
・サイン逓減曲線の要素長を正しく認識できず、要素を不連続で描画していた。
・DXF変換時に実寸図面への変換を可能とした。ミリメートルまでの精度で1:1の尺度で描画する。
・直線桁のとき描画範囲の延長ができていないラインがあった
○HAUNCH
・タイプ3のとき、ハンチ量の指定ではなく、天端高を指定したときにハンチ量を計算していなかった。
○HOSO
・舗装厚の自動決定時に収束しなかったときの処置を追加した。
縦断勾配、横断勾配の両方もしくは片方を自動として体積最小などで自動決定するときに収束しないと落ちていた。
○OPTION(APLINE,CRTCONX,FOOTING,GCROSS,MDVIEWER,GVIEWIG,LTOOL)
・ヘルプファイルの形式を従来のWinHELP形式(HLP)からHTML Help形式(CHM)に変更した。
○APLINE
・非常駐車帯の基準とできるラインが座標入力かIPのみであり、要素を持つラインでは編集できなかった。
一度設定した非常駐車帯のラインを編集しようとすると、基準ライン名が消えてしまい、始点、終点の側点も消えているため、「正しく側点を入力して下さい」のメッセージが出ており、基準ライン名も始点、終点の側点も入力できなかった。
・コントロールが無効になり、入力出来なくなる画面があった。
○GVIEWIG
・[照査]のボタンを削除した。
○LTOOL
・LDISTの横断名称が小文字のとき、LDISTの項目を表示すると大文字になり、計算エラーとなる不具合を修正した。
・OUTPUTデータ、SPANデータと紛らわしくないようにLDISTのツリーをトップレベルに上げた。
・基準ラインをまたいでクロスするラインがあるとき、累加幅が正しくなかった。
・途中で止まるラインがあるとき、累加幅が正しくなかった。



古い更新履歴
Ver.12.07(2005-11-18)
0)線形計算
・ネットワーク運用において、インストールフォルダ[\HyBRIDGE\LINER\OPTION](OPTIONフォルダ)に書込み権限を与えないとオプションプログラム[GPLOT,GVIEW,FOOTING,MDVIEWER]が起動できない不具合を修正した。
1)GDRAW(平面図・座標テーブル作成)
・ラインがポリライン(連続線分)とならない不具合を修正した。(Ver12.06のみにおいて発生する不具合)
Ver.12.06(2005-11-04)
0)線形計算
・ライン一覧において、既存のラインをコピーすると、どのタイプのライン設定においてもコピー後の設定方法が[要素をもつライン(簡易入力)]となる不具合を修正した。
・ライン設定の平行線において、複数のラインを1つのデータで作成すると、データが読み込めない場合がある不具合を修正した。
・ピア設定にピア出力データが読み込まれてしまう場合がある不具合を修正した。
・桁設定の確認図において、300セクション以上のセクションが描画されない不具合を修正した。
・コメントに[LINE DATA][SPAN DATA]等のパートを判別する構文と同じ文字列を記述すると、データが読み込めなくなる不具合を修正した。
・断面高さ設定において、入力データが80カラムを超えて作成される場合がある不具合を修正した。
・ライン一覧の簡易入力において、右車線の幅員にマイナスの距離を入力し、再度データを開くとプラスの距離となっている不具合を修正した。
1)GDRAW(平面図・座標テーブル作成)
・座標テーブルの座標値を右詰め文字として出力するようにした。
・座標テーブルの座標値セルの幅と高さを入力可能とした。
・出力フォントの全角と半角を選択可能とした。
2)APLINE(予備計算)
・IDSK連動において、連動ライン名が日本語の場合、測点の小数点以下が[.0000]となってしまう不具合を修正した。
・LINERラインデータ作成時に座標・測点の小数点以下6桁出力を可能とした。
・新規データにおいて、LINERラインデータ作成時、[漢字出力(SET KANJI)]をデフォルトととした。
・拡幅線の設定ダイアログで表示される小数点以下の桁数を環境設定-表入力から設定可能とした。
・平面図の右クリックメニュー[ライン上の任意点の座標計算]で、要素始点からの距離に[0.0]が入力できない不具合を修正した。
3)LTOOL(線形情報出力)
・ファイル出力において、[連続出力ファイル]がチェックされていると、連続出力のないタイプがファイル出力できなくなる不具合を修正した。
・クリップボードに何もない状態でないと表のコピーが行えない不具合を修正した。
・線形計算の桁設定で[複数個の点を結ぶ]を使用し、2点でライン設定した場合、単幅・累加幅がゼロとなってしまう不具合を修正した。
4)OUTLINE(SPACERへの連動)
・複数のINFLOADを作成した際、指定していないラインがINFLOAD2以降に連動される場合がある不具合を修正した。
5)MDVIEWER(ツール集)
・300セクション以上のセクションを出力している場合、プログラムが起動できない不具合を修正した。
6)PV(プロットファイルビューワ)
・「従来通りのレイヤー」か「CALS基準レイヤー」の選択したレイヤーDXFのみ出力する方法に変更した。
7)セットアップ
・JSP-LINERをセットアップから除外した。
Ver.12.05(2004-10-08)
0)線形計算
・ライン設定において、[要素変化点の拡幅線]を使用し、
 拡幅タイプを[要素ごとに指定]とした場合のコメントを修正した。
・画面に表示される測点が入力ピッチ通りにならない場合がある不具合を修正した。
・ピア設定において、[2点をを結ぶ]を使用すると、ピアが設定できない場合がある不具合を修正した。
1)GDRAW(平面図・座標テーブル作成)
・曲線の描画分割数が荒くなる場合がある不具合を修正した。
2)PV(プロットファイルビューワ)
・DXF形式変換時にCALS基準レイヤへ変換できる機能を追加した。
Ver.12.04(2004-08-13)
0)全般
・ライン+セクション数が127以上存在し、[桁設定]において折れセクションを使用した場合、オプションプログラムにおいて、折れセクションと認識されない場合がある不具合を修正した。

1)線形計算
・スパン簡易入力において、横桁を何も入力せず空白のまま完了すると、[桁設定]画面においてエラーとなる不具合を修正した。
・[座標変換]画面において、指定したセクションが、再度データを開くと別のセクションとなっている場合がある不具合を修正した。
・出力データで座標変換を行う際、2点の座標により設定されたピアを使用すると座標変換が誤っている不具合を修正した。

2)入力画面
・メニューバーの[ツール]MDSKOUTにおいて、出力される連動ファイルが誤っている不具合を修正した。

3)ハンチ計算
・計算ラインに多くのラインを指定すると計算が実行できない不具合を修正した。

4)LTOOL(線形情報出力)
・ラインの要素変化点にセクションを立てた場合、4方向交角が誤っている不具合を修正した。
・出力ラインの最初と最後のラインとの交点を持たないセクションの4方向交角が誤っている不具合を修正した。

5)MDVIEWER(ツール集)
・複数スパンを設定し、1スパン目の桁設定において折れ桁を使用していると、2スパン目以降の面積計算が誤っていた不具合を修正した。
Ver.12.03(2004-03-22)
0)線形計算
・[測点設定]画面において、要素番号を「1」以外とし、ピッチを「マイナス」と設定すると画面に表示される測点が誤っていた不具合を修正した。
・[出力オプション設定]画面において、マスタファイルを作成しないとしても、再度データを開くと作成するとなっている不具合を修正した。

1)図面作成
・寸法値を整数に四捨五入する際、誤って四捨五入が行われる場合のある不具合を修正した。

2)OUTLINE(SPACERへの連動)
・[初期データを自動作成]において、「G10」や「G20」等の主桁名称の1桁目がゼロの場合、連動できない不具合を修正した。

3)GCONVA(DXFファイルの変換)
・GDRAW/GPLOT/GVIEWにより作成されたDXFを「CAD製図基準(案)」(平成15年7月、国土交通省)に準拠したレイヤ構成(名称、色、線種)に変換する機能を追加した。
Ver.12.02(2004-02-27)
0)全般
・コマンドプロンプトからGUIを起動すると計算が実行できない不具合を修正した。

1)OUTLINE(SPACERへの連動)
・データを新規作成した際に、[初期データを自動作成]を実行せずに[コントロール]画面において追加ボタンを押すとプログラムが強制終了する不具合を修正した。
Ver.12.01(2004-02-10)
0)全般
・体験版が起動しない場合のある不具合を修正した。

1)線形計算
・「測点設定」で同じラインに対して複数の測点を入力した場合、「ライン設定」の測点が2番目以降の測点で変更される不具合を修正した。
・確認図、断面高さ設定において、「断面図」が反転する場合がある不具合を修正した。
・[編集]またはダブルクリックでピア設定補助ダイアログ「1点と角度を指定」を表示した場合、正しく表示されない不具合を修正した。
・[断面高さ設定]画面で「計算対象外ライン」を設定し「無効にする」をチェックするとチェックをはずした際に「計算対象外ライン」が無効になったままとなる不具合を修正した。
・[断面高さ設定]画面でWA,WAGを使用し、始終端内で止まっているラインをPHラインに指定すると正しく高さが計算できない場合がある不具合を修正した。
・スパン追加ダイアログにおいて、スパン名称の入力を促すメッセージを追加した。

2)GVIEW
・全要素長に対して非常に短い要素がある場合、平面図線形図、ピア設定図、小座標設定図が描画されない不具合を修正した。

3)APLINE(予備計算)
・要素設定でラインを設定した場合、非常駐車帯の基準ラインが設定できない不具合を修正した。

4)OUTLINE(SPACERへの連動)
・「△追加節点情報」 の「Z座標」、「シフト量」が保存できない不具合を修正した。
・横断名称がマイナスで始まる場合(例:-1)、[◎主桁情報]画面で例外の節点番号に設定できない不具合を修正した。
・連動スパンを指定して「実行」を行う場合、オプションの使用を制限した。

5)TextView(帳票ビューワ)
・入力データ数により、異常終了する場合のある不具合を修正した。
Ver.12.00(2003-09-02)
0)全般
・ダウンロードサービスに対応させた。
・社名表示の修正を行なった。

1)入力画面
・メニューバーの[ツール]のインデックスに誤りがあったため修正した。

2)OUTLINE(SPACERへの連動)
・スパンデータが複数ある場合に、1スパン目しか小座標を取り込まない不具合を修正した。
・追加節点情報のシートの項目名を”節点座標”から”節点番号”へ修正した。

3)舗装厚計算
・複数の計算範囲をまたいだラインの平均舗装厚が算出されない不具合を修正した。

4)LTOOL(線形情報出力)
・「セクション方向」の表示をする際、表の行数に誤りがり全セクション表示されない不具合を修正した。
・「断面チェック」において、CSV形式で連続ファイル出力した場合、全セクション出力されない不具合を修正した。
Ver.11.10(2003-02-26)
・セットアッププログラムに障害があったため修正した。
Ver.11.09(2002-12-11)
0)線形計算
・計算エラー発生時のメッセージを改ページコードの誤りを修正した。
・改ページコード、改行コードが一部正しく出力されない不具合を修正した。
・断面高さ設定のタイプWBの説明図の誤りを修正した。
・ピアの出力指定で出力ラインの簡易入力を実行したとき、出力ピアの簡易入力ダイアログが表示される不具合を修正した。
・◎スパン一覧◎桁設定[入力ダイアログ]の「複数個の点を結ぶ」ダイアログにおいて、座標値を入力できなかった不具合を修正した。

1)図面作成
・基本データの描画オプション「平面図」がセットされていないデータファイルを読み込んでもオプションがセットされる不具合を修正した。
・寸法線間隔の指定を可能とした。
・横断線の線種を変更するとバルーン引き出し線の線種も変わってしまう不具合を修正した。

2)OUTLINE(SPACERへの連動)
・連動スパンを名称で指定した場合に、データを正しく読み込めない不具合を修正した。
・データファイルを読み込むとき、小文字をすべて大文字に変換していたので、線形で小文字の出力名称をつけていたときに連動できない不具合を修正した。

3)TextView(帳票ビューワ)
・表示方法を一部変更した。

4)APLINE(予備計算)
・ラインの座標入力での[要素延長]コマンド、IP線形での[基線延長]コマンドの実行後に、表に正しい座標が入らないことがある不具合を修正した。

5)LINER入力ジェネレータ
・ラインの測点設定の画面で、表入力でエラーが発生することがあったため、セットアップに新しいバージョンのランタイム(OCX)を含めるようにした。
Ver.11.08(2002-08-20)
0)全般
・表形式でライン、セクション、スパンなどを入力する画面で、入力と選択の両方をできるようにした。
・オプションプログラムを起動するメニュー画面を作成した。
・ツールメニューに測点電卓を追加した。

1)線形計算
・折れたラインとセクションとの交角の計算方法を変更した。
・折れセクションの折れ点を通るラインが出力されないときの、ライン間の単幅の計算方法を変更した。
・NAME出力で、座標が離れた要素と接線方位角が一致しない要素を別々の警告で出力するようにした。
・データの編集画面で、平面図・断面図の印刷時の文字サイズを改善した。
・ライン追加時のライン記号のチェック(Ver11.06で追加)方法に誤りがあったのを修正した。
・座標変換の基準となるライン、セクションが未指定の状態で計算を行ったときに、エラーメッセージを表示してデータの編集画面に切り替わるようにした。
・円要素を基準とする4次拡幅のうち、始点側の幅員が終点側の幅員より大きい場合は計算を計算を実行できないようにした。
・ピア設定、桁設定画面で、エディットボックス上でキーボードのCtrl+Aを押すと全選択状態になるようにした。
・桁設定画面で描画のための計算の実行中にほかのスパンに切り替えようとすると不正終了したため、描画が終わるまではスパンを切り替えられないようにした。
・ピアとスパンの入力ダイアログメニューに、すべてのダイアログを閉じるボタンを追加した。
・縦断・横断情報を帳票出力するためのデータに存在しないデータ番号が指定されている場合に、計算時にそのデータを無効にしてデータエラーにならないようにした。
・マイナスピッチの場合にピアの簡易入力で作成したデータの距離が間違っていた不具合を修正した。
・2つ以上の測点データがあるとき、測点設定の画面で全入力項目を表示するようにした。
・縦断勾配・横断勾配の変化点の測点が昇順に指定されていない場合に、エラーメッセージを出力して計算を実行しないようにした。
・小数点以下5桁出力するオプションが正しく保存されない不具合を修正した。
・桁編集画面を表示した直後にスパン簡易入力機能を利用した場合に、ピアの順番が正しくソートされないことがある不具合を修正した。
・断面高さ設定の画面で、データが1つもないときに作図画面にジャンプしようとすると不正終了する不具合を修正した。
・測点、縦断、横断、断面高さのデータ整理番号が重複している場合に、エラーメッセージを表示してデータの編集画面にジャンプするようにした。
・ピアの測点入力で、ラインの支点からの距離を小数点以下6桁出力するようにした。

2)ハンチ計算
・旧形式でデータを保存する場合に、タイプ8のデータを作成できないようにした(新形式のみサポートのため)。
・「(舗装+床版)厚」の項目名称を変更できるようにした。
・罫線なし帳票を作成できるようにした。
・平面を設定した場合に、表紙より前に平面の設定情報が出力される不具合を修正した。

3)舗装厚計算
・舗装厚の照査画面を追加した。

4)図面作成
・橋長が短くて斜角がきつい場合に、直線桁を描画できないことがある不具合を修正した。

5)OUTLINE(SPACERへの連動)
・データ自動作成のアルゴリズムを改良した。
・横桁部材、格子形状のデータの前に出力するコメントを変更した。
・影響線載荷点のデータ(INFLINE)に、節点番号が重複して出力されることがある不具合を修正した。
・主桁部材番号の指定にも、節点番号と同様に例外の番号を指定できるようにした。
・データの自動作成時に、スパン番号がMDSK内の番号ではなく、1からの連番で出力される不具合を修正した。
・横断が交差する場合に、主桁ごとに節点の順番を並び替えるオプションを追加した。
・主桁と交点がないセクションが存在する場合の節点番号のふりかたを変更した。
・小数点以下の出力桁数を、4桁から6桁で選択できるようにした。
・主桁情報の画面で、節点・部材番号とZ座標とスパン番号の入力画面をグループボタンで切り替えられるデザインに変更した。
・横桁部材と格子形状のグループデータに、データを識別する名前をつ付けられるようにした。
・線形データを数学座標系で作成して座標変換をしていない場合に、座標を連動できない不具合を修正した。
・主桁数が12本以上の場合に、格子形状のデータを正しく作成できない不具合を修正した。
・横桁部材と格子形状のデータ用に、JIP-SPACERに表示できるコメントを指定できるようにした。

6)TextView(帳票ビューワ)
・A4縦2枚出力時の印刷文字の大きさを改善した。
・線形帳票のページを切り替えるツリーメニューを追加した。
・左端と上端の空白を詰めて画面に表示できるようにした。
・拡張子ごとに印刷レイアウトをカスタマイズできるようにした。

7)APLINE(予備計算)
・ツリーメニューをつけ、予備計算などのダイアログをそこから表示できるようにした。
・環境設定ダイアログの設定条件を整理した。
・登録ポイント一覧表と変数一覧表で、データの一括削除を可能にした。
・表コントロールの編集機能を改良した。
・新規ライン設定メニューを平面図画面の中に移動し、ツールボタンの位置も変更した。
・右車線のみの非常駐車帯をセットしたとき、そのラインを削除できなくなる不具合を修正した。

8)LTOOL(線形情報出力)
・角度の表示形式で、小数点以下の桁数に0か1を選択できるようにした。
・ラインごと、セクションごとに座標などを表示するタイプで、全ライン・全セクションの座標を連続してファイル出力できるようにした。

9)CRTCONX(オプションの図面ビューワ)
・背景色、レイヤをクリックしたときの色をカスタマイズできるようにした。
・平面図だけを描画したときは図面を最大化して表示し、複数の一般図を描画したときは図面を並べて表示するようにした。
Ver.11.07(2002-06-10)
0)全般
・Q&A質問用紙(JIP-LINERQA.txt)をインストールするようにした。

1)線形計算
・ラインの途中の要素がセットされていない状態で平面図を描画した場合に、エラーメッセージを表示するようにした。
・STOREした折れ桁を基準にSETTRANで座標変換を行なった場合に、正しい座標変換ができないことがある不具合を修正した。

2)ハンチ計算
・計算タイプ一覧画面の計算タイプの表で、現在の行を切り替えるとそれに対応する説明図を表示するようにした。
・帳票右上の舗装厚+床版厚に、負の値を出力しないようにした。

3)図面作成
・先頭のセクションとの交点がないラインは、初期値ではそのラインの始点位置から描画するように変更した。
・拡幅円・クロソイドの描画で無限ループに陥ることがある不具合を修正した。

4)OUTLINE(SPACERへの連動)
・ブロックの支間数を、SPACERの制限値である10径間までしか出力しないようにした。
・主桁上で特定の横断を連動しないように指定した場合に、桁編集出力用のデータ作成の途中で不正終了することがある不具合を修正した。

5)LINER入力ジェネレータ
・高さ算出点の設定画面で、適当でないラインの範囲を指定すると、それ以上データを作成することもキャンセルすることもできなくなる不具合を修正した。
Ver.11.06(2002-05-14)
0)全般
・オプションライセンスのチェック方法を変更した。
・ヘルプメニューにオンラインマニュアルを追加した。
・固定フォーマットのバッチデータ中に全角ブランクを含むデータファイルを読み込んだ場合に、カラムがずれないように自動修正するように改良した。
・セットアップ時に全オプションのマニュアルもHDにコピーするようにした。
・HOSO入力ジェネレータマニュアル(PDF)の内容に誤りがあったので差し替えた。
・データのコメントが重複して保存される不具合を修正した。
・ツリーメニューの図面作成の項目を、必須のデータとそうでないデータでグループ分けした。

1)線形計算
・拡幅ラインの設定で、1番目の要素を設定し忘れている場合にエラーメッセージを出力するようにした。
・測点設定の高さ関連のデータ編集画面で、リストボックスで表示するデータを切り替えたときに、対応する変化点のデータを入力する表コントロールの1行目を表示するようにした。
・ライン記号、縦横断データ記号など番号の入力が間違っている場合(L001やPH(001)など)に、メッセージを出力して再入力を促すようにチェック機能を強化した。
・要素変化点の座標が離れている場合に、要素表画面で座標を赤く表示するようにした。
・1データに記述できる記号・数値の数を200から500に拡張した(LINER1.EXE)。
・測点設定の画面で、測点を与える要素番号が2番目以降の場合に、平面図に測点の計算範囲が正しく描画されない不具合を修正した。
・横断勾配のデータ編集画面で、勾配変化位置の測点が正しく描画されないことがある不具合を修正した。
・交点計算の収束判定条件を変更した。
・出力指定で連番のセクション名を簡易的に記述できる指定方法を使用したときに、エラーになることがある不具合を修正した。
・4次拡幅の要素を基準に直角平行(||)のラインをセットしたとき、要素変化点を接続でき ない場合に警告のメッセージが表示されずに不正終了することがある不具合を修正した。
・帳票表紙の全角ブランクを半角ブランクに置き換えた(PDF変換時に罫線がずれるため)。
・LINER入力ジェネレータでラインやセクションの出力名称が10文字のデータを作成した場合に、データを正しく読み込めない不具合を修正した。
・スパンの座標変換で、X軸上の1点のセクションに出力しないセクションが指定されている場合に、画面にその記号が表示されない不具合を修正した。
・作図画面で文字拡大・縮小を実行した後に、図の描画範囲を実行前の状態に戻すようにした。

2)ハンチ計算
・舗装厚+床版厚が、全主桁で一定のスパンと主桁ごとに指定するスパンが混在している場合に、全スパンの帳票右上の舗装厚+床版厚の表示が最後のスパンのデータによって決まってしまう不具合を修正した。
・既存データをコピーして計算タイプを追加する場合に、計算タイプ番号がコピー元のデータの番号ではなく画面で入力された新規作成時の番号になってしまう不具合を修正した。
・旧形式でデータを保存した場合に、全主桁を計算するタイプ(6,7,11,15,16)で計算主桁名称が保存されない不具合を修正した。

3)舗装厚計算
・タイプ2とタイプ3で縦断勾配の収束条件を変更した(10%以上の縦断勾配が計算されなかったため)。

4)図面作成
・複数スパンを連続して描画する場合で、スパンの境界にあるセクションで同一名称ライン上の座標値が異なる場合に、座標テーブルを分けて描画するようにした。
・図面作成後にテンポラリファイルが残らないようにした。
・描画しないセクションを指定している場合に、座標テーブルの値がずれることがある不具合を修正した。
・線形で出力名称が指定されていないセクションがある場合に、不正終了することがある不具合を修正した。

5)OUTLINE(SPACERへの連動)
・線形帳票・図面をツールメニューから表示できるようにした。
・自動作成時に名称が「CHECK」「ピア」「支承」のスパンは連動しないようにした。
・最初の指定した主桁のHSHIFTで、シフト量を指定しないと線形の計画高が出力される不具合を修正した。
・最初の横桁部材データで、部材番号の設定方法に「前の部材番号からの連番」が指定されている場合に、エラーメッセージを出力するようにした。
・XY座標のみの場合は、Z座標のシフト量に関するデータを編集できないようにした。
・線形マスタファイルに W のデータが1つもない場合は、格子モデルを作成するようにした。
・ファイルメニューに「不要ファイル削除」を追加した。
・前回のバージョンから、複数のOUTLINEデータを作成した場合に2つ目以降の%STATICS,%INFLOADをJIP-SPACERで読み込めなくなった不具合を修正した。
・途中の横断から出現する主桁がある場合に、主桁断面力図作成用のデータを正しく出力しない不具合を修正した。
・JIP-SPACER で載荷ブロックのコメントに横断名称が表示されるようにした。

6)LINER入力ジェネレータ
・測点設定の測点の入力欄でデータを上書きして編集しようとすると、余計な文字が表示される不具合を修正した。
Ver.11.05(2001-12-07)
0)全般
・入力データに誤りがあって正常に計算が行なわれなかった場合のメッセージを改善した。
・データファイルの先頭にバージョン番号を保存するようにした。

1)線形計算
・テキストの入力データファイルで、出力指定のデータ(PRTL,PRTS)を継続行マークを用いて記述してある場合に、桁設定と出力指定の両方に重複してデータを取り込んでしまう不具合を修正した。
・ライン設定の要素入力(簡易入力)で、画面を切り替えたときに始点側半径が無限大のクロソイド要素の曲率中心方向が右側から左側に変わってしまうことがある不具合を修正した。

2)ハンチ計算
・旧形式の計算タイプ17のデータフォーマットは正しく読み込めないので(サポート外)、記述されていた場合はデータファイルを読み込んだ後に警告のメッセージを表示するようにした。

3)舗装厚計算
・舗装範囲のデータ編集画面に「ライズ量を考慮する場合の曲線は2次放物線です。」という説明文を追加した。

4)格点間距離チェック
・データファイルにライン名とセクション名を保存する際、3行以上にまたがる場合に正しく保存できない不具合を修正した。

5)OUTLINE(SPACERへの連動)
・データエラーは検出できないがSPACER連動ファイルが作成されなかったとき、実行情報を表示してメッセージを表示するようにした。
・主桁とラインの座標が桁あふれで10カラムに入らない場合にエラーメッセージを出力するようにした。
Ver.11.04(2001-11-28)
0)全般
・CDのセット時に自動再生されるセットアップ画面から、バージョンアップ手順の説明書を表示できるようにした。
・スタートメニューから表示できる「始めにお読みください」文書の説明を改訂した。
・スタートメニューに環境変数の設定ツール(HyBENV)を追加登録した。

1)線形計算
・2つのライン上で距離をとった直線のセクションを複数本同時にセットした場合に、2本目以降のセクションが1本目と同じ位置にセットされる不具合を修正した。
・入力データに不備があるときに、そのデータの入力画面にジャンプする機能を強化した。

2)ハンチ計算・格点間距離チェック
・ラインとセクションの参照ダイアログで正しい名称を表示できないことがある不具合を修正した。

3)図面作成
・用紙サイズの初期値を無指定からA1に、描画枠の初期値を枠なしから4隅に変更した。
・セクション間寸法線で指定した基準主桁が、作成する図面に反映されないことがある不具合を修正した。
・座標テーブルの出力項目数を変更した場合にレイヤの割り当てがずれる不具合を修正した。

4)LTOOL(線形情報出力)
・ライン情報でサイン曲線と3次曲線の要素タイプを表示できるようにした。

5)OUTLINE(SPACERへの連動)
・節点番号が異なり座標が一致する点が存在する場合に、エラーメッセージを出力するオプションを追加した。
・長さ0の部材が存在する場合に、エラーメッセージを出力するオプションを追加した。
・データエラーがあった場合に、エラーメッセージだけを表示する画面を用意してエラーの内容が目立つようにした。
・データの追加ダイアログで、コピー元のデータとして最後のデータが選択されているように改良した。
・主桁断面力図作成(%DRAFT)用のデータを作成するオプションを追加した。
・データの自動作成機能を改良した。
・横桁部材情報と格子形状の画面で、データ入力できなくなることがある不具合を修正した。

6)TextView(帳票ビューワ)
・スパンの小座標系を表示している状態から、大座標しかないスパンに表示を切り替えたとき表示されるページがずれる不具合を修正した。
Ver.11.03(2001-11-14)
0)全般
・全オプション標準装備になったためプロテクトの仕組みを変更した。
・ソフトが異常終了した場合、次回起動時に「データのバックアップファイルを開いてみて下さい」というメッセージを表示するようにした。
・ヘルプメニューにオンラインサポートを追加した。
・データの新規作成時にワンポイントのガイドを表示できるようにした。

1)線形計算
・ラインの設定画面で、設定したラインのドロップダウンリストをドロップダウンさせた状態で矢印キーを押すと、ラインの設定方法が変わってしまう不具合を修正した。
・拡幅線の設定画面に入力説明を追加した。
・平面図の描画画面で、ライン名称・セクション名称などの描画/非描画を切り替えられる。
・出力指定と要素表のデータで、出力名称が長いと1行に記述できる文字数を超えてしまうことがある不具合を修正した。
・平行線の設定画面に注意事項の表示を追加した。
・ピアとセクションの断面図を描画できるようにした(折れセクションを除く)。
・縦断勾配と横断勾配の画面に予備計算機能を追加した。
・断面高さ設定画面で、断面図のラインを直接クリックしてデータを作成できるようにした。
・断面高さ設定画面に横断勾配データの参照ダイアログを追加した。
・ピアとスパンの出力指定画面で、ラインを並び替える基準セクションと、セクションを並び替える基準ラインを選択できるようにした。また、簡易入力の機能を改良し、すべてのデータを削除できるボタンを追加した。
・入力データの読み込み時に、無効になっているスパンの出力指定データが有効になってしまうことがある不具合を修正した。
・入力データが間違っていて計算ができない場合に、そのデータの編集画面にジャンプする機能を強化した。
・ツールメニューにMDSKOUT(MightyBridgeへの連動)の実行を追加した。
・同じ主桁記号につけられる出力名称がスパンデータによって異なる場合に、平面図に主桁名称が正しく描画されない不具合を修正した。
・スパンを削除しようとするとき、そのスパンが出力データで指定されていたら一緒に削除するかどうかを指定できるようにした。
・値の入力欄で小数点の前の0を省略できるようにした。

2)ハンチ計算
・計算タイプ4で、ハンチ量を基準主桁と同じにすることができるようにした。
・出力項目名称の変更で、指定できる名称の長さを6文字から8文字に拡張した。
・桁の天端高一覧表のタイトルに、出力項目名称の変更を反映させるようにした。
・主桁ごとに舗装厚と床版厚を指定した場合に、保存したデータファイルを正しく読み込めない不具合を修正した。

3)舗装厚計算
・天端高が1000mを超える場合に、帳票の桁天端一覧表に正しい値が出力されない不具合を修正した。

4)図面作成
・図面の文字サイズを、名称・寸法値・座標テーブルで別々に指定できるようにした。
・座標テーブルにXYZ座標と天端高を出力できるようにした。
・寸法線関連のデータのデフォルト値を、CAD製図基準に合わせて変更した。
・ライン間寸法線の引き出し線の入力項目に余計なデータが表示される不具合を修正した。
・セクション上にない点で主桁が切れている場合に、セクション上の点までしか主桁を描画できていない不具合を修正した。

5)PV(図面ビューワ)
・DXF形式への変換時にフォントを選択できるようにした。
・作成したDXF形式のファイルで、座標テーブルの値の小数点の位置が揃うようにした。

6)TV(帳票ビューワ)
・余白が広すぎたのでレイアウトを変更した。

7)APLINE(予備計算)
・要素変化点での拡幅線の基準ラインに、任意の測点での拡幅線を指定した場合に、基準ラインの要素が正しく表示されない不具合を修正した。
・表に出力する小数点以下の桁数で、6桁を指定できるようにした。

8)LTOOL(線形情報出力)
・セクションごとにライン方向の座標を表示・出力できるようにした。
・ラインとセクションの交点における4方向の交角を、ライン方向・セクション方向の並びで表示・出力できるようにした。

9)OUTLINE(SPACERへの連動)
・線形マスタファイルの名称を指定した場合に正しく動作しない不具合を修正した。
・格子形状のデータ編集画面で画面がグレイになって編集できなくなることがある不具合を修正した。
・従来はスタートメニューから実行するようになっていたが、LINERのGUIのツールメニューからも起動できるようにした。
・SPACERの桁編集出力のデータ作成機能を追加した。

10)LINER入力ジェネレータ
・入力したラインの座標が、シフト量を差し引いた値に変わってしまうことがある不具合を修正した。
・ラインデータの描画設定ダイアログで[OK]ボタンを押して閉じるとプログラムが不正終了する不具合を修正した。

11)HAUNCH入力ジェネレータ
・計算スパンを指定した後に線形マスタファイルのスパン名称が変更されると、ジェネレータを起動できなくなる不具合を修正した(マシンによってはこの不具合は発生しない)。

12)MDVIEWER(MDSK情報抽出)
・ラインの要素数が30を超える場合にエラーが発生する不具合を修正した(INTER32.DLLを修正)。

13)TextView(帳票ビューワ)
・印刷時に全角文字の罫線を線に置き換えて出力する設定時に、プリンタによって罫線がずれることがある不具合を修正した。
・A4縦で出力できるようにした。
Ver.11.02(2001-09-05)
0)線形計算
・測点、縦断勾配、横断勾配の設定画面で、通常はほとんど入力することのないデータの表示・非表示を、設定で切り替えられるようにした(初期値は表示しない)。
・設定済みのライン(主桁)、セクションの参照ダイアログに、不要な説明が残っていたのを削除した。

1)ハンチ計算
・計算タイプ一覧画面に、データの作り方の説明を追記した。

2)OUTLINE(SPACERへの連動プログラム)
・データ作成と計算実行手順のわかりにくかった画面に、設定画面の挿絵と説明を追記した。
・操作マニュアルをCD-Rに含めるようにした。
Ver.11.01(2001-08-31)
0)プログラムの追加
・SPACERへの連動プログラムOUTLINEもインストールされるようにした。

1)画面表示の変更・改良
・距離の単位表記、角度の値の入力方法がなかった画面に説明を追加した。
・ライン一覧画面の「設定値」という表示を、「幅員(m)(平行線のみ)」に変更した。
・座標変換、出力データのデータ作成方法の説明を補足した。
・ピア設定画面の[ピア設定]、桁設定画面の[桁設定]ボタンの名前を、[入力ダイアログ]に変更した。
・桁設定画面の「主桁:S、横桁:G」という説明は逆なので、「主桁:G、横桁:S」に修正した。

2)データ作成の不具合修正
・1点と角度を指定してピアを設定する補助ダイアログで、直線に対して角度をふる場合に作成されるデータに構文上の誤りがあったのを修正した。
・格点間距離チェックの張り出し長画面で、計算セクションが正しく保存されない不具合を修正した。
・舗装厚計算の帳票をメニューから表示できないようになっていた不具合を修正した。

3)帳票・図面
・格点間距離チェックの帳票で、小数点の前の0が欠落することがある不具合を修正した。
・格点間距離チェックの帳票で、基準ラインが重複して出力されることがある不具合を修正した。
・線形情報出力ツールで、ハンチ計算をしていない点のハンチ量が0と出力されることがある不具合を修正した。
・DXFファイルにした座標テーブルをAutoCADで見ると数値と罫線が重なっていたので、1行の高さを広げた。
Ver.11.00(2001-08-27)
JIP-LINERとして新規リリース(JSP-LINERからの置き換え版)。
Ver.10.08(2001-08-17)
■ プロテクト
・オプションライセンスに対応した。

■ 出力ファイル拡張子名称の変更
・各プログラムが出力するファイルの拡張子の名称に一貫性をもたせるように変更した。
 ファイルの種類  旧名称  新名称
 HAUNCH実行情報   HL2   HL1
 HAUNCH帳票     HL1   HL2
 HOSO実行情報    H2L   HS1
 HOSO帳票      HSL   HS2
 ※HAUNCHはハンチ計算オプション、HOSOは舗装厚計算オプションを示す。

■ 仕様変更
・LINER入力ジェネレータでLINERデータを作成したとき、そのファイルがすでに存在する場合に、LINERのデータのみを更新し、ほかの部分を残すように変更した。
・GVIEW入力ジェネレータで、データを更新して画面を切り替えると必ず「データを更新しますか?」というメッセージが表示されていた。通常のソフトと同様に、データを更新したのに保存せずに終了しようとした場合だけメッセージを出すように変更した。

■ 不具合修正
・総合メニューのLINERマネージャで、「最新ファイル状態」コマンドが機能していなかったのを修正した。